Установка:

Для установки libkf5syntaxhighlighting-tools в Ubuntu / Linux Mint / Debian, введите в Терминал:

sudo apt update
sudo apt install libkf5syntaxhighlighting-tools

Подробная информация о пакете:

Подсветка синтаксиса

Это автономная реализация механизма подсветки синтаксиса Kate. Он предназначен как для текстовых редакторов, так и для простого выделенного текстового рендеринга (например, HTML), поддерживающего интеграцию с настраиваемым редактором, а также готовый к использованию подкласс QSyntaxHighlighter.

Предоставляет дополнительные инструменты для libkf5syntaxhighlighting5

Список зависимостей: