Установка:

Для установки libcgi-application-plugin-anytemplate-perl в Ubuntu / Linux Mint / Debian, введите в Терминал:

sudo apt update
sudo apt install libcgi-application-plugin-anytemplate-perl

Подробная информация о пакете:

модуль, поддерживающий любую систему шаблонов в CGI :: Application

CGI :: Приложение :: Плагин :: AnyTemplate позволяет использовать любую поддерживаемую систему шаблонов Perl с использованием единого согласованного интерфейса. В настоящее время поддерживаемые системы шаблонов включают HTML :: Template, HTML :: Template :: Expr, HTML :: Template :: Pluggable, Template :: Toolkit, Template и Petal. Вы можете получить доступ к любой из этих систем шаблонов, используя тот же интерфейс. Таким образом, вы можете использовать один и тот же код и переключать системы шаблонов «на лету». Этот подход имеет много применений. Например, это может быть полезно при переносе вашего приложения из одной системы шаблонов в другую.

Список зависимостей:

  • libcgi-application-basic-plugin-bundle-perl

    пакет основных плагинов для CGI :: Application

  • libcgi-application-perl

    рамки для создания многоразовых веб-приложений

  • libclone-perl

    модуль для рекурсивного копирования типов данных Perl

  • libclone-pp-perl

    модуль для рекурсивного копирования типов данных Perl

  • perl

    Практический язык извлечения и отчета Ларри Уолла