Установка:

Для установки php-codecoverage в Ubuntu / Linux Mint / Debian, введите в Терминал:

sudo apt update
sudo apt install php-codecoverage
php-codecoverage — сбор, обработка и рендеринг для покрытия кода

Подробная информация о пакете:

Сбор, обработка и рендеринг для покрытия кода

  • Зависимости:

  • libjs-bootstrap

    HTML, CSS и JS framework

  • libjs-jquery

    Библиотека JavaScript для динамических веб-приложений

  • libjs-twitter-bootstrap

    HTML, CSS и JS toolkit из Twitter

  • php-common

    Общие файлы для пакетов PHP

  • php-file-iterator

    Реализация FilterIterator для PHP

  • php-text-template

    Простой шаблонный движок

  • php-token-stream

    Обтекание расширением токенизатора PHP

  • php-tokenizer

    Это виртуальный пакет. Для определения виртуальных пакетов см. Политику Debian.

  • php-xml

    DOM, SimpleXML, WDDX, XML и XSL для PHP [по умолчанию]

  • phpunit-code-unit-reverse-lookup

    Посмотреть, что принадлежит строке кода - компонент PHPUnit

  • phpunit-environment

    Функциональность для обработки сред HHVM / PHP - компонент PHPUnit

  • phpunit-version

    Библиотека, которая помогает при управлении номером версии проектов, основанных на Git-PHP