Установка:

Для установки python-os-faults в Ubuntu / Linux Mint, введите в Терминал:

sudo apt update
sudo apt install python-os-faults
python-os-faults — Библиотека OpenStack с ошибкой (Python 2)

Подробная информация о пакете:

Библиотека OpenStack с ошибкой (Python 2)

Библиотека выполняет разрушительные действия внутри облака OpenStack. Он обеспечивает уровень абстракции для различных типов облачных развертываний. Действия выполняются как драйверы (например, драйвер DevStack, драйвер Fuel, драйвер Libvirt, драйвер IPMI).

Этот пакет устанавливает библиотеку для Python 2.

  • Зависимости:

  • ansible

    Система управления конфигурацией, развертывания и выполнения задач

  • python

    Интерактивный высокоуровневый объектно-ориентированный язык (ветка 2.x)

  • python-iso8601

    Модуль Python для анализа дат ISO 8601 - Python 2.x

  • python-jsonschema

    Реализация JSON-схемы (проект 3 и 4) - Python 2.7

  • python-oslo.i18n

    Утилиты интернационализации Oslo - Python 2.x

  • python-oslo.serialization

    Утилиты для сериализации, особенно JSON - Python 2.x

  • python-oslo.utils

    Набор служебных функций для OpenStack - Python 2.x

  • python-pbr

    Вставлять полезные и разумные поведения по умолчанию в setuptools - Python 2.x

  • python-pyghmi

    Общая инициатива по управлению оборудованием (IPMI и другие)

  • python-six

    Библиотека совместимости Python 2 и 3 (интерфейс Python 2)

  • python-yaml

    Парсер YAML и эмиттер для Python

  • python2.7

    Интерактивный объектно-ориентированный язык высокого уровня (версия 2.7)

  • python-appdirs

  • python-click