Установка:

Для установки ruby-magic в Ubuntu / Linux Mint / Debian, введите в Терминал:

sudo apt update
sudo apt install ruby-magic
ruby-magic — Связывание Ruby FFI с libmagic

Подробная информация о пакете:

Связывание Ruby FFI с libmagic

  • Зависимости:

  • libmagic1

    Признать тип данных в файле с помощью «волшебных» чисел - библиотеки

  • ruby

    Интерпретатор объектно-ориентированного языка сценариев Ruby (версия по умолчанию)

  • ruby-ffi

    Загружать динамические библиотеки, связывать функции из кода ruby