Установка:

Для установки libgmp-dev в Ubuntu / Linux Mint / Debian, введите в Терминал:

sudo apt update
sudo apt install libgmp-dev

Подробная информация о пакете:

Инструменты разработчиков многоарифметической библиотеки

Этот пакет разработки предоставляет файлы заголовков и символические ссылки, позволяющие компилировать и связывать программы, которые используют библиотеки, предоставленные в пакете libgmp10.

В этом пакете присутствуют как C, так и C ++ привязки. Пакет libstdc ++ — dev должен использовать привязки C ++.

Библиотека MPFR (с плавающей запятой с несколькими точками) была включена, но с тех пор была перенесена в пакет libmpfr-dev.

Зависимости:

  • libgmp10

    Многоточечная арифметическая библиотека

  • libgmpxx4ldbl

    Арифметическая библиотека с несколькими значениями (привязки C ++)